Outage Alert for Kerio Cloud US1 datacenter
Incident Report for GFI Software
Resolved
As of 08/Jul/18 5:35 AM, the outage for Kerio Cloud US1 datacenter has been resolved.
Posted 9 days ago. Jul 08, 2018 - 09:59 UTC
Identified
Outage Alert:
At 08/Jul/18 5:30 AM, Kerio Cloud US1 datacenter is experiencing an outage. We are aware of the issue and currently working on the resolution. We will update this page regularly so please check back for updates related to timing.
Posted 9 days ago. Jul 08, 2018 - 09:51 UTC
This incident affected: GFI SaaS Products (Kerio Cloud US1 datacenter).