Email Filtering Issue with SpamRazer

Incident Report for GFI Software

Resolved

This incident has been resolved. If you continue to experience issues, please contact Support.
Posted Feb 09, 2026 - 01:30 UTC

Identified

We have implemented a potential fix and are currently testing it to resolve the issue with legitimate emails being misclassified as spam. Further updates will follow.
Posted Feb 04, 2026 - 13:21 UTC

Investigating

We are investigating an issue where SpamRazer is incorrectly classifying some legitimate emails as spam. Our team is working with the relevant systems to identify the cause and mitigate the impact. Further updates will be shared as more information becomes available.
Posted Jan 20, 2026 - 14:20 UTC
This incident affected: GFI MailEssentials (Spam features).