Outage Alert for Kerio Cloud EU
Incident Report for GFI Software
Resolved
This incident has been resolved.
Posted 10 days ago. May 13, 2019 - 12:43 UTC
Identified
Outage Alert:
At around 13-May-2019 @ 12PM CET, Kerio Cloud EU server is experiencing an outage. We are aware of the issue and currently working on the resolution. We expect to have it resolved by 30 minutes. We will update this page regularly so please check back for updates related to timing.
Posted 10 days ago. May 13, 2019 - 12:13 UTC
This incident affected: GFI SaaS Products (Kerio Cloud EU1 datacenter).