Planned Maintenance for: GFI OneConnect, GFI Faxmaker and the majority of GFI Websites
Incident Report for GFI Software
Resolved
The scheduled maintenance has been completed at 10/Mar/18 08:50 AM UTC
Posted 6 months ago. Mar 10, 2018 - 08:57 UTC
Investigating
On 10/Mar/18 07:30 AM UTC, GFI OneConnect, GFI Faxmaker and the majority of GFI Websites will undergo scheduled maintenance.
Posted 6 months ago. Mar 10, 2018 - 07:52 UTC