Certificate error for the GFI website on Chrome/some browsers
Incident Report for GFI Software
Resolved
We received the updated certificates from our provider and these will no longer trigger the browser alert received by some users when visiting our pages via the Chrome Browser. We updated our sites to use these certificates and the issue is now resolved.
Posted May 03, 2022 - 22:15 UTC
Identified
We have received an indication that the Google Chrome, and potentially other, browsers are experiencing certificate validation issues for the GFI website. We have confirmed the incident and will provide more details once we identify the root cause. As a workaround, try using a different browser or clicking "advanced" on the warning.
Posted May 02, 2022 - 22:04 UTC
This incident affected: GFI Archiver (Website), GFI FaxMaker Online (Website), and GFI MailEssentials (Website).