MailEssentials stops filtering incoming messages
Incident Report for GFI Software
Resolved
As of 02:30 UTC, we have shared a potential solution for the issue related to Email Filtering.
We created a fix and shared it, and we can confirm that the issue is no longer reproducible after the application of the patch.
We apologize for any inconvenience or difficulty you may have experienced as a result of this issue.
Posted Apr 26, 2023 - 02:53 UTC
Update
Our Development team has still been actively engaged in iterative deployments for the identified trouble with email filtering.
We have seen some issues with the initial fix, so we are now working to address them before an official release.

We thank you for your patience.
Posted Feb 17, 2023 - 09:58 UTC
Update
Our Development team has been actively engaged in iterative deployments for the identified trouble with email filtering. While we have seen positive results from testing the initial fix, we are working to address the remaining trouble identified during testing before release.
Posted Feb 02, 2023 - 16:40 UTC
Identified
We are currently working on a fix for the issue relating to MailEssentials randomly stopping to filter all incoming messages until the Exchange server is rebooted.

The build with a fix is being tested internally and with selected customers.
Posted Jan 20, 2023 - 11:46 UTC
Investigating
We are currently investigating an issue relating to MailEssentiels randomly stopping to filter all incoming messages until the Exchange server is rebooted.

We are working to identify the source of the issue reported and will provide further updates as they become available.
Posted Jan 15, 2023 - 18:32 UTC
This incident affected: GFI MailEssentials (Website).