We are continuing to work on a fix for this issue.
Posted Mar 03, 2026 - 17:20 UTC
Identified
We have identified the root cause of the issue and are actively working on a resolution. During this time, anti-phishing updates and detection may not function as expected. We will provide further updates as soon as more information becomes available.
Posted Mar 03, 2026 - 17:11 UTC
This incident affects: GFI MailEssentials (Anti-phishing definitions updates).