Mail Essentials emails not appearing in dashboard after latest MS updates
Incident Report for GFI Software
Resolved
We are pleased to share that our development team has successfully tested and released GFI MailEssentials 21.7 Patch 5. This Patch addresses the issue of Windows Updates causing issues with MailEssentials failing to filter emails. We can no longer reproduce the issue identified.

For more information refer to: https://support.mailessentials.gfi.com/hc/en-us/articles/360018451119-Manually-installing-product-updates

We apologize for any inconvenience or difficulty you may have experienced as a result of this issue.
Posted Feb 02, 2024 - 05:45 UTC
Investigating
We are aware that there is a known issue after recent Microsoft updates where email is not appearing on the Dashboard and items are not being blocked as expected.

Our development team is currently investigating to locate the root cause.
Posted Jan 17, 2024 - 15:13 UTC
This incident affected: GFI MailEssentials (Website).